Skip to content.

plone.org

Sections
Personal tools
You are here: Home » Development » Teams » User Interface Team » Browser Support
Views
FrontPage »

Browser Support

last edited 1 day ago by eaon

Important Note to Readers: This is a document in draft and aimed at versions of Plone that don't exist yet!

We claim(ed) that Plone works in any browser. Or at least the "Any Browser" button made users think Plone works on every browser. What does "works" or "is usable" mean, and at what level is each browser supported?

This page provides detailed Information about what we (want/will) support in which browser.

Basically any browser is what i think we should be after, but this is problematic with old browsers or browsers like Internet Explorer, Konqueror and Netscape 4 that parse things they actually don't understand.

Four Level Support Concept

Thats why Chad came up with a "degrading" Concept with 4 Levels.

  1. Information Access
    • All information and function accessible by any user agent.
    • CSS 1 Skinning (does not include layout)
  2. Graphical Styling
    • Full support for Plones CSS 2 appearance
    • Everything above
  3. Basic UI Features
    • Action menus
    • Date widget
    • Everything above
  4. Advanced UI Features
    • Kupu (previously known as EpozNG?)
    • XMLHttpRequest?
    • Everything above

The problem is, some browsers interpret CSS that they don't understand - or they don't interpret everything from css2 - so what we'd need to do is disable css2 with javascript for browsers like iCab or Amaya - is everyone fine with that?

tom is not - he wants us to use hacks! getting one for amaya shouldn't be a problem with his w3c connections, although there aren't any "decent" ones for iCab... does anyone know one?

Specific List

Specific list of which browsers should be supported on which level. (Currently suggested by Michael)

Level 4
  • Internet Explorer 6.0 and 5.5
  • Mozilla (based) Browsers: 1 and up
  • Opera 7.something
Level 3
  • Safari 1 and up
  • OmniWeb? 4.5 and up
  • Mozilla (based) Browsers: ~0.9
  • Konqueror 3.2.1 and up (according to Jochen Knut aka jok2)
Level 2
  • Mac IE 5
  • Opera 6 or 5+
Level 1
  • Everything Else!

You can edit the list but please leave notes what you changed and why.

 

Powered by Plone

This site conforms to the following standards: